Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > General Tech Talk

Thread Title
Tokico

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04-24-2007, 04:38 AM
piano_maniac's Avatar
Bronze Member
 
Join Date: Oct 2006
Location: Phoenix AZ
Posts: 182
iTrader: (0)
piano_maniac is on a distinguished road
Send a message via AIM to piano_maniac Send a message via Yahoo to piano_maniac
Icon13 Tokico

Well i got those brand new tokico illumina shocks and they were sitting in my garage for literary 6 months. I simply didn't have time to put them on, then i had some other stuff to deal with and i wasn't focusing on my car for a period of time. Anyway, this Saturday i went to put them on in a shop around here and after those guys put the two rear shocks on my car, they started working on the front ones and guess what... One of them blew right in front of me, and the second one was cracked a little bit and when he tried to put in on, the top cracked all the way and the second one blew too. I was there and i saw everything, they didn't do anything wrong and they blew out of nowhere.
The whole point is that i got those shocks from a friend of mine and after i called him and told him about this whole thing, i found out something really interesting. Those shocks were sitting in his garage for about 4 years. I dont know if that affected the shocks in any way but this whole situation sucks so bad. Right now i have tokico illuminas in the back, my old stock blew shocks in the front and neuspeed race springs and my car is so bouncy that it got to that point when its not driveable anymore.
In conclusion, i think its stupid to try to be cheap when it comes to parts for cars. I regret not saving a couple of hundreds and buying some tein basics but its kinda late for that.
__________________
Reply With Quote
  #2 (permalink)  
Old 04-24-2007, 05:48 AM
Uncle Buck's Avatar
Gold Member
 
Join Date: Jan 2007
Location: Rapid City, South Dakota
Posts: 570
iTrader: (0)
Uncle Buck is on a distinguished road
Send a message via MSN to Uncle Buck Send a message via Skype™ to Uncle Buck
i hear ya man.... i just replaced my struts on the front of my car cus they were really bad.... i had the hydro bounce all the time.... kinda sucked especially when i had drop coils on the front none the less.... but to make things worse... everytime i hit a bump my hood move hardcore...low and behold my strut is hitting underneath my hood.... turns out i forgot to put a washer in my strut before remounting it
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:31 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.