Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 5th Gen Honda Prelude

Thread Title
Hiccups and maybe a bad ecm?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02-04-2013, 06:34 PM
I'm New
 
Join Date: Jan 2013
Location: Dallas, TX
Posts: 11
iTrader: (0)
White99lude is on a distinguished road
Hiccups and maybe a bad ecm?

I mentioned it in the new member area, but anyway it is randomly hiccuping(best way I could discribe it,lol) when its in gear, when I'm moving no sign of any problems. Last week the speedo started dancing around and the check engine light came on and D4 started flashing. I looked it up and found out that it was the VSS, so I took it to NTB to have them do a diagnostics. They said the VSS was new and the transmission was great, but they say that the ECM had old codes that weren't cleared off and that's why the engine light and D4 flashing happened. They cleared it off and reset the ECM and told me its the ECM that's the issue It was all fine until this past weekend when I took it to wash it, afterwards the speedo started "dancing" again. I don't know if its related, but when I brought the car home from the dealership it had been raining A LOT and noticed the back seat was wet..starting looking around online and found out about the problem with water getting in threw the tail lights due to worn out gaskets. I took them off and cleaned them off and put them on tight to try to keep the water out until the new gaskets arrive. Concluding, at the car wash this past weekend I made sure to stay clear off the tail lights with the pressure wash and only noticed a little bit of water in the trunk, so I just cleaned it up and moved on.. so could I have got one of the harnesses wet and that start up the problem again? Oh the hiccups never went away either...LOL! Its a 14yr old car, so I knew there were going to be some issues that would show up..but damn! Sorry for the long post, tried to get every bit of info on here. Thanks guys!
Reply With Quote
  #2 (permalink)  
Old 02-04-2013, 07:10 PM
bykfixer's Avatar
Supreme Member
Photobucket
 
Join Date: Aug 2012
Location: could you repeat the question?
Posts: 11,121
iTrader: (4)
bykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond repute
Re: Hiccups and maybe a bad ecm?

Hicups? Please be a bit more descriptive. Idling only, driving at certain speeds only? Random times?
We could name a bunch of potential issues like clogged fuel filter, old gas, fouling spark plug, failing tranny. But if you could tell us more details it'll help us help you.
__________________


Quote:
Originally Posted by ogsmakdade View Post
welcome to site Carl
...is a golden car fax kinda like a golden ticket? Sure hope willy wonka didn't put any snozberries in your motor.
Quote:
Originally Posted by elspectro29 View Post
Only seen the first one, 15 years ago in theaters. Plan on keeping it that way. Get off my lawn.
Quote:
Originally Posted by Lindso View Post
I remember my first thread, asking what a noise was when I got going 110mph.
Pretty much got flamed for driving like a jackass and was told to slow down. And I'll be damned, slowing down fixed it.

God's Not Dead
Reply With Quote
  #3 (permalink)  
Old 02-04-2013, 07:49 PM
I'm New
 
Join Date: Jan 2013
Location: Dallas, TX
Posts: 11
iTrader: (0)
White99lude is on a distinguished road
Re: Hiccups and maybe a bad ecm?

It only does it in gear while sitting still, only once in a while.. maybe its a misfire? Once I take off it goes away. I wonder if someone at the dealership put regular unleaded instead of premium? I have only been using premium. Maybe I need to do a video documentation,lol! Thank you for your help.

Last edited by White99lude; 02-04-2013 at 08:02 PM.
Reply With Quote
  #4 (permalink)  
Old 02-04-2013, 09:00 PM
bykfixer's Avatar
Supreme Member
Photobucket
 
Join Date: Aug 2012
Location: could you repeat the question?
Posts: 11,121
iTrader: (4)
bykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond repute
Re: Hiccups and maybe a bad ecm?

Is it awful, annoying or just noticeable?
Check out the tranny failure thread. Not trying to be alarming. But 97/98 were bad bad bad. You should read it because like cancer, if you catch it early.

The speedo thing has me baffled.
__________________


Quote:
Originally Posted by ogsmakdade View Post
welcome to site Carl
...is a golden car fax kinda like a golden ticket? Sure hope willy wonka didn't put any snozberries in your motor.
Quote:
Originally Posted by elspectro29 View Post
Only seen the first one, 15 years ago in theaters. Plan on keeping it that way. Get off my lawn.
Quote:
Originally Posted by Lindso View Post
I remember my first thread, asking what a noise was when I got going 110mph.
Pretty much got flamed for driving like a jackass and was told to slow down. And I'll be damned, slowing down fixed it.

God's Not Dead
Reply With Quote
  #5 (permalink)  
Old 02-05-2013, 02:26 PM
rocker22dallas's Avatar
Gold Member
 
Join Date: Sep 2012
Location: Southwest MI
Posts: 849
iTrader: (1)
rocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond reputerocker22dallas has a reputation beyond repute
Re: Hiccups and maybe a bad ecm?

x2 on the auto transmission failure thread. there are also several suggestions in it that may prolong the use of the transmission. such as avoiding use of the slap shift.

5th Gen Auto Transmission Failure Guide

Last edited by rocker22dallas; 02-05-2013 at 02:36 PM.
Reply With Quote
  #6 (permalink)  
Old 02-05-2013, 03:02 PM
I'm New
 
Join Date: Jan 2013
Location: Dallas, TX
Posts: 11
iTrader: (0)
White99lude is on a distinguished road
Re: Hiccups and maybe a bad ecm?

Thanks everybody, I covered it in my other thread. It's the 2nd clutch pressure switch and a bad fuel cap that came up on the computer at autozone. From what I read on other forums if it is left unchanged will cause even bigger issues. The car is driving fine right now and shifting smoothly, so I'm going to try to get the part on payday Thursday and change it out hopefully. The "hiccup" situation could be tied to that maybe, but I also read a bad fuel cap can cause the issue, which is what also came up on the diagnostic. Should I consider getting the tranny fluid changed anyway as well? I think that was part of the dealerships servicing, but who knows if they used a high Iquality fluid or not. I also have a trans cooler sitting in the garage that I think might be a good idea to put to good use
Reply With Quote
  #7 (permalink)  
Old 02-05-2013, 04:12 PM
bykfixer's Avatar
Supreme Member
Photobucket
 
Join Date: Aug 2012
Location: could you repeat the question?
Posts: 11,121
iTrader: (4)
bykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond repute
Re: Hiccups and maybe a bad ecm?

Fuel cap could be a slight vacuum leak causing your system confusion. That could be your hiccup. I had a chevy once the CEL would come on if cap not tight. Vacuum loss.

Your car should already have a tranny cooler. Right? Some say no change tranny fluid. Gunk build up keeps stuff sealed. If you know the previous owner changed it regular then go right ahead.
__________________


Quote:
Originally Posted by ogsmakdade View Post
welcome to site Carl
...is a golden car fax kinda like a golden ticket? Sure hope willy wonka didn't put any snozberries in your motor.
Quote:
Originally Posted by elspectro29 View Post
Only seen the first one, 15 years ago in theaters. Plan on keeping it that way. Get off my lawn.
Quote:
Originally Posted by Lindso View Post
I remember my first thread, asking what a noise was when I got going 110mph.
Pretty much got flamed for driving like a jackass and was told to slow down. And I'll be damned, slowing down fixed it.

God's Not Dead
Reply With Quote
  #8 (permalink)  
Old 02-05-2013, 09:20 PM
I'm New
 
Join Date: Jan 2013
Location: Dallas, TX
Posts: 11
iTrader: (0)
White99lude is on a distinguished road
Re: Hiccups and maybe a bad ecm?

Hmm, I will have to look into that..I figured it didn't have one from the factory. I notice that you have over 200k on your lude, awesome! I hope mine does the same, I'm going to try to get all the kinks worked out!
Reply With Quote
  #9 (permalink)  
Old 02-05-2013, 09:52 PM
bykfixer's Avatar
Supreme Member
Photobucket
 
Join Date: Aug 2012
Location: could you repeat the question?
Posts: 11,121
iTrader: (4)
bykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond reputebykfixer has a reputation beyond repute
Re: Hiccups and maybe a bad ecm?

^^it doesn't mention the motor and clutch have 40k. A previous owner abused it pretty good. But it is still in great shape for a 16 year old hot rod.

Good luck getting the kinx worked out. You won't regret it.
__________________


Quote:
Originally Posted by ogsmakdade View Post
welcome to site Carl
...is a golden car fax kinda like a golden ticket? Sure hope willy wonka didn't put any snozberries in your motor.
Quote:
Originally Posted by elspectro29 View Post
Only seen the first one, 15 years ago in theaters. Plan on keeping it that way. Get off my lawn.
Quote:
Originally Posted by Lindso View Post
I remember my first thread, asking what a noise was when I got going 110mph.
Pretty much got flamed for driving like a jackass and was told to slow down. And I'll be damned, slowing down fixed it.

God's Not Dead
Reply With Quote
  #10 (permalink)  
Old 02-11-2013, 04:50 PM
I'm New
 
Join Date: Jan 2013
Location: Dallas, TX
Posts: 11
iTrader: (0)
White99lude is on a distinguished road
Re: Hiccups and maybe a bad ecm?

Hiccups and odd shifting fixed*knocks on wood* It was a 2nd clutch pressure switch after all. Now to address the "dancing speedo" it only does it 50mph to around 70mph,lol! It does have a new vss, I checked the connector under the hood and it seems to be fine. If only this thing had a reset button,lol!
Reply With Quote
  #11 (permalink)  
Old 02-11-2013, 05:43 PM
okfirearms's Avatar
Silver Member

 
Join Date: Oct 2011
Location: Tulsa, OK
Posts: 304
iTrader: (1)
okfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond repute
Re: Hiccups and maybe a bad ecm?

Quote:
Originally Posted by White99lude View Post
Hiccups and odd shifting fixed*knocks on wood* It was a 2nd clutch pressure switch after all. Now to address the "dancing speedo" it only does it 50mph to around 70mph,lol! It does have a new vss, I checked the connector under the hood and it seems to be fine. If only this thing had a reset button,lol!
You can swap out the VSS to be sure, only like 10 bucks or so on eBay. With a 10mm socket and extension you can have it changed in about 15 minutes. My speedo used to jump a bit and that solved it.
__________________
The only thing better than driving a fast car is shooting a big-ass gun.

Reply With Quote
  #12 (permalink)  
Old 02-12-2013, 01:05 PM
I'm New
 
Join Date: Jan 2013
Location: Dallas, TX
Posts: 11
iTrader: (0)
White99lude is on a distinguished road
Re: Hiccups and maybe a bad ecm?

I'm thinking I might as well, maybe the one the dealer put in is a faulty one. I will see about ordering it today and hope for the best. I'm just happy its not doing the crazy stuff it was doing. Thanks for the feedback.
Reply With Quote
  #13 (permalink)  
Old 02-12-2013, 01:38 PM
okfirearms's Avatar
Silver Member

 
Join Date: Oct 2011
Location: Tulsa, OK
Posts: 304
iTrader: (1)
okfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond reputeokfirearms has a reputation beyond repute
Re: Hiccups and maybe a bad ecm?

Quote:
Originally Posted by White99lude View Post
I'm thinking I might as well, maybe the one the dealer put in is a faulty one. I will see about ordering it today and hope for the best. I'm just happy its not doing the crazy stuff it was doing. Thanks for the feedback.
Np. Its definitely worth doing and ez pz. Its possible that the little keyed input shaft on the VSS sensor is stripped and/or slipping. When I replaced mine you could tell that it had failed in that way
__________________
The only thing better than driving a fast car is shooting a big-ass gun.

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:18 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.