Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 5th Gen Honda Prelude

Thread Title
Need Help with EGR and O2 CEL

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09-09-2012, 12:39 PM
I'm New
 
Join Date: Aug 2012
Location: Utah
Posts: 17
iTrader: (0)
fu2ufer is on a distinguished road
Need Help with EGR and O2 CEL

Hi Guys, I'm new to the thread, just bought a 2001 Type SH a couple weeks ago but I'm having some CEL issues that are starting to get expensive.

I'm getting a PO133 and PO401. Codes popped up when I was test driving it. The dealership I bought it from 'fixed' it with an O2 sensor replacement. Test drove it again with no issues so I signed all the paperwork and left. After driving ~40 miles, CEL came back on with the same codes.

I took the car to my local Honda dealership and they stated the EGR valve was bad. They replaced it yesterday and I picked it up with no CEL. After starting it up and driving it a little this morning, CEL is back on, with the same two codes.

I'm starting to wonder if the AEM intake or the Noname header have anything to do with it. The AEM is the current version thats Cal emissions approved so I'm leaning towards the header. Header has no markings on it to identify who made it.

I've seen a couple posts with similar issues with the O2 sensor CEL but I didn't see anything with the EGR and O2 CEL's tripped. Please help cause I'm about to sacrifice the car to the gods by pouring gas on it and lighting it aflame.
Attached Images
File Type: jpg 2012-09-09_10-29-37_6.jpg (81.4 KB, 13 views)
File Type: jpg 2012-09-09_10-29-45_645.jpg (66.4 KB, 17 views)
File Type: jpg 2012-09-09_10-30-40_56.jpg (51.2 KB, 18 views)
Reply With Quote
  #2 (permalink)  
Old 09-09-2012, 12:45 PM
Racon88's Avatar
Platinum Member
 
Join Date: Mar 2012
Location: Chandler Arizona
Posts: 1,273
iTrader: (0)
Racon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond repute
Re: Need Help with EGR and O2 CEL

You need to do the egr ports. There is a video on here and write ups on here how to do it.
Reply With Quote
  #3 (permalink)  
Old 09-09-2012, 01:06 PM
I'm New
 
Join Date: Aug 2012
Location: Utah
Posts: 17
iTrader: (0)
fu2ufer is on a distinguished road
Re: Need Help with EGR and O2 CEL

Quote:
Originally Posted by Racon88 View Post
You need to do the egr ports. There is a video on here and write ups on here how to do it.
Thanks dude. I watched the video and checked out the car afterwards to see if those ports had been touched when they did the work. Turns out they didn't do it so I'll jump on getting it done.
Reply With Quote
  #4 (permalink)  
Old 09-09-2012, 01:37 PM
Racon88's Avatar
Platinum Member
 
Join Date: Mar 2012
Location: Chandler Arizona
Posts: 1,273
iTrader: (0)
Racon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond reputeRacon88 has a reputation beyond repute
Re: Need Help with EGR and O2 CEL

Yeah man it's a tedious little job. A lot of people try just doing the valve first but t doesn't do much. Mine sucked to do on my 4th gen because the plugs are welded in. So I had to grind all of the weld off and make my own plugs because the ones from Honda weren't made to replace the plugs from the 4th gen. They realized they will need to be taken out easier and fixed it for the 5th gens.
Reply With Quote
  #5 (permalink)  
Old 09-09-2012, 03:58 PM
01PreludeBlue's Avatar
Grand Member

 
Join Date: Dec 2011
Location: San Antonio
Posts: 1,788
iTrader: (5)
01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute
Send a message via MSN to 01PreludeBlue Send a message via Yahoo to 01PreludeBlue
Re: Need Help with EGR and O2 CEL

A bad/clogged EGR can cause a o2 sensor code?
__________________
2001 Honda Prelude Electron Blue Pearl
2000 Honda Prelude parts car (5 speed swap donor)
Reply With Quote
  #6 (permalink)  
Old 09-09-2012, 05:01 PM
Silver Member
 
Join Date: Nov 2011
Location: Pinole, CA
Posts: 455
iTrader: (1)
Travis is on a distinguished road
Re: Need Help with EGR and O2 CEL

I'm not sure about the o2 sensor but if they put a new egr valve in (which it probly didn't need) and the code still came up, you need to clean the ports. It's not that hard I did mine a couple weeks ago and it cleared my CEL
__________________
Reply With Quote
  #7 (permalink)  
Old 09-09-2012, 05:02 PM
01PreludeBlue's Avatar
Grand Member

 
Join Date: Dec 2011
Location: San Antonio
Posts: 1,788
iTrader: (5)
01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute01PreludeBlue has a reputation beyond repute
Send a message via MSN to 01PreludeBlue Send a message via Yahoo to 01PreludeBlue
Re: Need Help with EGR and O2 CEL

Maybe they changed the wrong sensor? Just a thought.
__________________
2001 Honda Prelude Electron Blue Pearl
2000 Honda Prelude parts car (5 speed swap donor)
Reply With Quote
  #8 (permalink)  
Old 09-10-2012, 07:51 AM
Bronze Member
 
Join Date: Aug 2012
Location: South FL
Posts: 134
iTrader: (0)
Guicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond reputeGuicar has a reputation beyond repute
Re: Need Help with EGR and O2 CEL

Go and bitch to that dealership. If they claimed they fixed the problem and really didn't (I mean they told you to buy a new one for Christ's sake). . . then it's their problem if the problem still persists.
Reply With Quote
  #9 (permalink)  
Old 09-11-2012, 05:43 PM
Cthulhuy's Avatar
Silver Member
 
Join Date: Jan 2011
Location: Dallas, Texas
Posts: 309
iTrader: (1)
Cthulhuy has a spectacular aura aboutCthulhuy has a spectacular aura about
Send a message via Skype™ to Cthulhuy
Re: Need Help with EGR and O2 CEL

Clean your EGR ports. I'm surprised that coming out from the dealership that they would of noticed that, but didn't.
Reply With Quote
  #10 (permalink)  
Old 09-18-2012, 03:30 PM
I'm New
 
Join Date: Aug 2012
Location: Utah
Posts: 17
iTrader: (0)
fu2ufer is on a distinguished road
Re: Need Help with EGR and O2 CEL

Thanks for all the help guys. The ports were so clogged up on #1 and #2, I couldn't even tell there was a port there. After cleaning all of them and replacing the O2 sensor, I'm passing emissions.

I found a neat trick for pulling the port plugs that works better than a slide hammer. I drilled and tapped the plug like the service bulletin said, but used a round spacer, screw and washer to pull the plug. Just tighten the screw with the washer and spacer on it and the plug comes right out. In my case, a washer is a small nut, a spacer is a huge nut and a screw is a screw. I dropped the proper setup into the abyss under the intake manifold.
Attached Images
File Type: jpg 2012-09-11_18-10-46_829.jpg (111.8 KB, 12 views)

Last edited by fu2ufer; 09-18-2012 at 03:42 PM.
Reply With Quote
  #11 (permalink)  
Old 09-18-2012, 03:53 PM
Not So New
 
Join Date: Dec 2008
Posts: 30
iTrader: (0)
Thotograph is on a distinguished road
Re: Need Help with EGR and O2 CEL

Very interesting, glad to hear you got your CEL issues sorted.

I'm hesistant to do the ports b/c drilling/metal shavings + my intake manifold makes me nervous. I think my car realized I wasn't feeling up to the repair b/c the code recently went away (possibly due to using SeaFoam in my gas for a few fill ups).

I think I'm still going to do the job (when I can draft some skilled hands to help). The odd thing is the plugs I was sold from the dealership aren't anything like the brass solid looking port plugs on my intake manifold. I'm assured by the parts counter guy that I have the right bits, but they're completely different vs. what I see under the hood. Anyone care to comment?
Reply With Quote
  #12 (permalink)  
Old 09-19-2012, 07:20 PM
I'm New
 
Join Date: Aug 2012
Location: Utah
Posts: 17
iTrader: (0)
fu2ufer is on a distinguished road
Re: Need Help with EGR and O2 CEL

Ya the new ports are supposed to look different. In the DIY section under the thread for the eGR port video, theres a link to Honda's actual service buletin and it shows this difference.

Quote:
Originally Posted by mckinleymorganfield View Post
Found this related service bulletin www.pleasurizer.com/Egrpreludetsb.pdf

The napafit video was great, but it left out the scary part of drilling and tapping etc. I am going to continue to search for more detailed instructions as I lack the skill and bravery to take this on without more info.
Reply With Quote
  #13 (permalink)  
Old 09-20-2012, 11:37 PM
prelude2war's Avatar
Junior Member
 
Join Date: Jul 2012
Posts: 72
iTrader: (0)
prelude2war is on a distinguished road
Re: Need Help with EGR and O2 CEL

And they go in hollow end up/rounded side down. I used the fat end of a nail punch to insert the plugs. This job cleared my cel.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:36 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.