Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 5th Gen Honda Prelude

Thread Title
Speed sensor/cruise control

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08-12-2012, 02:47 PM
Junior Member
 
Join Date: Jul 2012
Location: Pensacola, Florida
Posts: 81
iTrader: (0)
CB900fer is on a distinguished road
Speed sensor/cruise control

Okay, I know it's a common problem, and I've searched some things about it but I want some more info.

I bought a cruise control on/off switch (dashboard) from Autozone (lifetime warranty)...I plugged it in and cruise control worked great. I went on a long trip (in upstate NY now from florida), and about 10 hours into the trip my speedometer started fritzing out. I'm assuming it's my vehicle speed sensor. The thing is, the speedo works intermittently, and it seems to be in conjunction with my cruise control. Let me explain...I was driving with my cruise on, and then my speedo starts fluctuating everywhere. I shut the cruise off and a few minutes later the speedo is working fine. I leave it alone for a few min, and then turn the cruise back on...works great for about 10 miles, then speedo fritzes again. Shut the cruise off, and speedo won't recover this time. Play with the cruise buttons a little bit and the speedo works again. I did this a few times, but eventually the speedo quit altogether (for about 500 miles).

My question is this: is it possible my "new" cruise control switch is causing the Vehicle speed sensor to act up? It almost seems like the sensor is overheating or something, and takes a while to cool down....or maybe it's just a bad connection. I'll probably just take the sensor off and clean it to see if that helps, but I really don't want to spend $100 on a new sensor.
Reply With Quote
  #2 (permalink)  
Old 08-12-2012, 08:15 PM
I'm New
 
Join Date: Jun 2012
Posts: 18
iTrader: (0)
darkgsxr is on a distinguished road
Re: Speed sensor/cruise control

im kinda confused your doesnt have cruise? if not i dont get how it works with just a elec. connection, and no vacuum. it sounds like the switch is drawing to much power like u said when it gets hot speedo no worky. if it does have cruise stock what the hells the switch for. if your talking about the button on the dash going bad just wire it so the cruise is always on
Reply With Quote
  #3 (permalink)  
Old 08-14-2012, 05:47 PM
Junior Member
 
Join Date: Jul 2012
Location: Pensacola, Florida
Posts: 81
iTrader: (0)
CB900fer is on a distinguished road
Re: Speed sensor/cruise control

Well, I went ahead and bought the speed sensor for $72 from Advance auto, and everything is working great again. Hopefully it will last. It has a limited lifetime replacement, so we'll see.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control anonymous_lude 4th Gen Honda Prelude 11 09-09-2010 12:54 PM
cruise control f22prelude 4th Gen Honda Prelude 2 02-15-2010 09:23 PM
Cruise control 99lude General Tech Talk 1 10-07-2009 06:17 AM
cruise control hardwhite 4th Gen Honda Prelude 12 08-22-2007 01:44 PM
cruise control steelheart 3rd Gen Honda Prelude 4 06-20-2007 02:20 PM


All times are GMT -4. The time now is 12:42 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.