Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 5th Gen Honda Prelude

Thread Title
Just installed my P28 ECU.. Something wrong?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08-26-2009, 05:29 PM
Platinum Member
 
Join Date: Sep 2007
Location: Kissimmee, FL
Posts: 1,222
iTrader: (0)
LudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond repute
Just installed my P28 ECU.. Something wrong?

Alright so I just installed my p28 ecu from MDPC20653.

It is supposebly a p28 with an h22 basemap.. I/H/E.. and it has a 2-step at 3k and a rev limiter at about 7.5k.

So I go ahead and install this thing today as it came in the same time as my obd2 to obd1 conversion harness. here are the results

The car feels sluggish at low rpms.. I heard its because the p28 doesnt control the IAB's therefore suffers from low end torque... so that I can understand.

The check engine light is on. That i dont understand.

I also cant feel VTEC at all.. It feels like a civic single cam.


NOW, I understand that the best thing to do is to fully build this thing at a tune shop. But at least, I mean at LEAST, I thought it could run fine with the h22 basemap that it has.. (also because the person that sold it to me claims that it ran fine for I dunno how many years..

So, can anyone help me decide if I should keep it like that or switch back to my p13 ecu? Or is there a quick fix to this?
Reply With Quote
  #2 (permalink)  
Old 08-26-2009, 06:56 PM
Bustr's Avatar
Platinum Member
ROTM!
 
Join Date: Aug 2006
Location: ny
Posts: 1,388
iTrader: (9)
Bustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond reputeBustr has a reputation beyond repute
Send a message via AIM to Bustr
Re: Just installed my P28 ECU.. Something wrong?

well... i would find out the code is first. obviously you have now stepped down to obd1. so you ll have to jump the two wire plug (blue plug w/ red and green wire) then turn the key to the on position and flash the cel to retrieve the code. at least you can see whats going on. now the secondaries or iabs... you can disable to have them run open instead (helps top end). if you look at your intake manifold.... on the right hand side...(driver side) behind your fuel pressure regulator is your iab... unplug the vaccum line that goes to it. then cap off that open vaccum line. you should feel somewhat of a difference. did the person who sold you this tell you what chip copy it is??? mugen, jun, skunk2, spoon etc?
__________________
MY ALL MOTOR?<.....click


MY TURBO ?<.....click

NEVER TELL ME IT CAN"T BE DONE
Reply With Quote
  #3 (permalink)  
Old 08-26-2009, 07:59 PM
Bronze Member
 
Join Date: Jun 2007
Location: MD
Posts: 174
iTrader: (1)
mdpc20653 is on a distinguished road
Re: Just installed my P28 ECU.. Something wrong?

Pm'd with number to call me.
__________________
To each his own....don't worry what others think...just spend money! PO.com member for life

MarylanD Prelude Club - R.I.P. gone but not forgotten
Reply With Quote
  #4 (permalink)  
Old 08-26-2009, 10:27 PM
mr_y82's Avatar
Platinum Member
 
Join Date: May 2008
Location: poor ass appalachia...
Posts: 1,703
iTrader: (8)
mr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond reputemr_y82 has a reputation beyond repute
Re: Just installed my P28 ECU.. Something wrong?

I'd say run the p13 until you get it resolved...

you really do need to have it tuned to the specific engine... I know that eCtune allows the p28 to operate and adjust the IABs... I thought hondata did... do others not?

I did lose power (p28 link in sig) with my basemap p28 compared to the p13 on the day I bought it and had it tuned... tuning is an (expensive) must. :(

Quote:
Originally Posted by LudeLove99 View Post
. I heard its because the p28 doesnt control the IAB's therefore suffers from low end torque...
or a lack thereof

Last edited by mr_y82; 08-26-2009 at 10:29 PM.
Reply With Quote
  #5 (permalink)  
Old 08-27-2009, 09:30 AM
Gold Member
 
Join Date: Jan 2009
Location: Floor-eeduh
Posts: 549
iTrader: (0)
ShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond reputeShoofIsLudin has a reputation beyond repute
Send a message via AIM to ShoofIsLudin
Re: Just installed my P28 ECU.. Something wrong?

u can just T into a line from the IM and split it off to the IAB actuator. U'll have use of it. So they won't be closed all the time. Or you could just take the vac line off the actuator and it'll be open all the time.

There's something not jiving with ur setup. Check the code. The lack of power in the lower rpms IS NOT from the IABs not being controlled. If anything, u'd feel sluggish in higher RPMs.
__________________
Reply With Quote
  #6 (permalink)  
Old 08-27-2009, 04:23 PM
orbslude's Avatar
Gold Member
 
Join Date: Jan 2009
Location: The shores of Strong Island
Posts: 540
iTrader: (-2)
orbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond reputeorbslude has a reputation beyond repute
Send a message via AIM to orbslude
Re: Just installed my P28 ECU.. Something wrong?

oooo coulda told u this was a bad idea..
__________________


1-CLEAN-SH

NYPOC

Quote:
Originally Posted by BB2H22A4 View Post
You want to get some pizza and f*ck?

WHAT, YOU DON'T LIKE F*CKING PIZZA!?
Quote:
Originally Posted by Si Speed View Post
That's ****in' success baby!
Reply With Quote
  #7 (permalink)  
Old 08-27-2009, 05:39 PM
Platinum Member
 
Join Date: Sep 2007
Location: Kissimmee, FL
Posts: 1,222
iTrader: (0)
LudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond reputeLudeLove99 has a reputation beyond repute
Re: Just installed my P28 ECU.. Something wrong?

alright so the infamous problem was that the seller brought me the wrong ECU. He had 2 p28's. One was h22 basemap and the other one was for another motor.

yep I was using the wrong one. so sorry and thank you guys for trying to help.

All I need now is to finish my full exhaust (hytech rep with high flow cat mated to my greddy evo) and then give it a street tune. But for now I'm just gonna run my stock p5m ecu for now until then.

Anyone know where I could find a good tuner in orlando? and how much would a street tune aproxx. be?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I wonder what's wrong ? 1998luder 5th Gen Honda Prelude 13 07-27-2008 09:47 AM
What Is Wrong With My Car? s2kbabe1 5th Gen Honda Prelude 11 05-03-2008 07:09 PM
H23 gone wrong 99PreludeSh Auto Showoff 23 04-16-2008 02:03 AM
is something wrong with my car??? kongee 4th Gen Honda Prelude 1 08-29-2007 04:48 PM
what is wrong maverick General Tech Talk 2 03-28-2007 10:37 PM


All times are GMT -4. The time now is 10:26 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.