Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 4th Gen Honda Prelude

Thread Title
speedo gauge messed up

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-25-2015, 05:07 PM
MY FIRST POST YEAH!
Photobucket
 
Join Date: May 2014
Posts: 1
iTrader: (0)
SethS is on a distinguished road
speedo gauge messed up

I changed my gauge cluster cause it was sun faded and after I put the needles in they just stuck and they won't move. The rpm will go up bit sticks. I tryed a spare cluster I had and it did the same thing. So at this point the rpm gauge and speedo gauge are stuck and I can't read them. Please help!
Reply With Quote
  #2 (permalink)  
Old 01-25-2015, 06:00 PM
SoFlaKidd's Avatar
Grand Member
 
Join Date: Apr 2011
Location: locked in the basement
Posts: 4,151
iTrader: (1)
SoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond reputeSoFlaKidd has a reputation beyond repute
Re: speedo gauge messed up

messing with the needles will usually cause them to not work right after
__________________
Quote:
Quote:
Originally Posted by M0B5TA View Post
welcome. I got some bad news, nobody wins at the prelude game lol
Florida residents join our Facebook Page
https://www.facebook.com/groups/Flor...ludes/?fref=nf
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
El Gauge Cluster - Speedo light out? (NOT gas & temp) Terror 4th Gen Honda Prelude 0 01-05-2013 03:13 PM
Temperature gauge messed up/ maybe messing with heater? Crewchief1 5th Gen Honda Prelude 1 10-11-2012 10:05 PM
Fuel Gauge is messed up? xCarl94x 4th Gen Honda Prelude 5 04-07-2011 12:03 AM
Gas gauge dead & speedo cutting out... Irish 3rd Gen Honda Prelude 15 03-25-2010 06:40 AM
HELP!!! Temperature Gauge is messed up CampinCracker 5th Gen Honda Prelude 1 04-12-2009 01:32 AM


All times are GMT -4. The time now is 12:30 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.