Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 4th Gen Honda Prelude

Thread Title
Speedometer not Working

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-24-2012, 10:43 AM
BlkBb4u's Avatar
Silver Member
 
Join Date: Jul 2011
Location: Cleveland
Posts: 404
iTrader: (5)
BlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to all
Icon8 Speedometer not Working

Recentlly did a H22a4 swap and everything was fine for a day or soo until the speeometer just went out on me,before it whent the needle from the Mph side would jump up and down till finally just died,So I figured bad VSS So I changed that Sensor twice and still nothing. I also checked the wires too the sensor and they were fine. I Even swaped out Clusters thinking I had a faulty one But Nothing!

I'm kinda running out of ideas here and would really appreciate Some Help

Info about the Car:

5 speed
PS Delete
Vtec those not Kick in (since car dosnt know how fast its goin)
Everything else in the Cluster work except Mph
__________________
Honda
Reply With Quote
  #2 (permalink)  
Old 01-24-2012, 02:45 PM
Bronze Member
 
Join Date: Nov 2011
Location: Las Vegas.NV
Posts: 172
iTrader: (0)
UR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond repute
Re: Speedometer not Working

i had a 92 accord with the same problem .... try to connect it directly... two of the wireson the VSS are for power jump those directly to the battery and one of them is for signal to the cluster jump that one to the connector using a wire or something... i cant remmember which cable is which but you can find a scamatic online!
Reply With Quote
  #3 (permalink)  
Old 01-24-2012, 03:17 PM
BlkBb4u's Avatar
Silver Member
 
Join Date: Jul 2011
Location: Cleveland
Posts: 404
iTrader: (5)
BlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to all
Re: Speedometer not Working

That sounds like my only option rite now,now time for a lil searching on which wires which and any chance that accord of yours was vtec?? Cuz im hoping in Solving My Speedo problem that vtec will funtion

btw: I have no CEl and Im running a P13 ecu
__________________
Honda

Last edited by BlkBb4u; 01-24-2012 at 03:20 PM.
Reply With Quote
  #4 (permalink)  
Old 01-24-2012, 04:37 PM
Bronze Member
 
Join Date: Nov 2011
Location: Las Vegas.NV
Posts: 172
iTrader: (0)
UR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond reputeUR_FUKED3_2 has a reputation beyond repute
Re: Speedometer not Working

no man no vtec! but you do need the VSS to be working for vtec... it had a engine replaced and then it died it happens alot on swaps !
Reply With Quote
  #5 (permalink)  
Old 01-24-2012, 04:41 PM
twokexlv6coupe's Avatar
little green ghouls, buddy!!
Photobucket
 
Join Date: Apr 2006
Location: kitten mittens
Posts: 17,844
iTrader: (9)
twokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond repute
Send a message via AIM to twokexlv6coupe
Re: Speedometer not Working

Did you replace just the top, electrical sensor of the VSS?
Or the entire assembly, including the helical gear that goes into the tranny?
__________________

1995 Honda Prelude SE Turbo; 250whp, 275wtq @ 10psi Soldddd!!!

2000 Acura TL; DD
2005 Stage2.5+ Subaru WRB STi : RzKar!
Ivey Tuned - Advan - Cobb - Rallispec - CP - Perrin - ACT - KillerB - Carillo - TurboXS - Defi - Innovate - Walbro - DeatschWerks - Feal - H&R - Alpine - Infiniti - Curt

2001 Kawasaki STX1100 D.I. - Sold!
2007 Sea-Doo RXT 215; ET 127 +3 S/C impeller, DIY 3" intake, DIY resonator delete/free flow exhaust, DIY oil catch can, Rule 500gph bilge pump


Quote:
Originally Posted by Brash View Post
But you need that scoop on the hood. Is it true that they're big enough to fit your lunch box and all your camera gear in it?
Reply With Quote
  #6 (permalink)  
Old 01-24-2012, 04:45 PM
BlkBb4u's Avatar
Silver Member
 
Join Date: Jul 2011
Location: Cleveland
Posts: 404
iTrader: (5)
BlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to all
Re: Speedometer not Working

Quote:
Originally Posted by twokexlv6coupe View Post
Did you replace just the top, electrical sensor of the VSS?
Or the entire assembly, including the helical gear that goes into the tranny?
Just replaced the top electrical sensor
__________________
Honda
Reply With Quote
  #7 (permalink)  
Old 01-24-2012, 04:57 PM
twokexlv6coupe's Avatar
little green ghouls, buddy!!
Photobucket
 
Join Date: Apr 2006
Location: kitten mittens
Posts: 17,844
iTrader: (9)
twokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond repute
Send a message via AIM to twokexlv6coupe
Re: Speedometer not Working

Might need to replace the entire assembly than. There's one bolt that's holding a tab down that holds the VSS assembly in the tranny..... and that tab somehow broke off on one of mine

Check to make sure the bottom assembly is seated in the tranny correctly.
__________________

1995 Honda Prelude SE Turbo; 250whp, 275wtq @ 10psi Soldddd!!!

2000 Acura TL; DD
2005 Stage2.5+ Subaru WRB STi : RzKar!
Ivey Tuned - Advan - Cobb - Rallispec - CP - Perrin - ACT - KillerB - Carillo - TurboXS - Defi - Innovate - Walbro - DeatschWerks - Feal - H&R - Alpine - Infiniti - Curt

2001 Kawasaki STX1100 D.I. - Sold!
2007 Sea-Doo RXT 215; ET 127 +3 S/C impeller, DIY 3" intake, DIY resonator delete/free flow exhaust, DIY oil catch can, Rule 500gph bilge pump


Quote:
Originally Posted by Brash View Post
But you need that scoop on the hood. Is it true that they're big enough to fit your lunch box and all your camera gear in it?
Reply With Quote
  #8 (permalink)  
Old 01-24-2012, 06:38 PM
BlkBb4u's Avatar
Silver Member
 
Join Date: Jul 2011
Location: Cleveland
Posts: 404
iTrader: (5)
BlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to all
Re: Speedometer not Working

Quote:
Originally Posted by twokexlv6coupe View Post
Might need to replace the entire assembly than. There's one bolt that's holding a tab down that holds the VSS assembly in the tranny..... and that tab somehow broke off on one of mine

Check to make sure the bottom assembly is seated in the tranny correctly.
Ok Cool ill check that out 2moro Thanks
__________________
Honda
Reply With Quote
  #9 (permalink)  
Old 01-24-2012, 09:38 PM
M_Stack's Avatar
Silver Member
 
Join Date: Jan 2011
Location: Brampton, Ontario
Posts: 272
iTrader: (0)
M_Stack is on a distinguished road
Re: Speedometer not Working

yeah you might have to replace the speedo gear in the differential assembly..
Reply With Quote
  #10 (permalink)  
Old 01-24-2012, 10:15 PM
BlkBb4u's Avatar
Silver Member
 
Join Date: Jul 2011
Location: Cleveland
Posts: 404
iTrader: (5)
BlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to all
Re: Speedometer not Working

Ok cool imma see if I can find one at my Local JY there's plenty of accords in there and if I'm not mistaken there the same
__________________
Honda
Reply With Quote
  #11 (permalink)  
Old 01-26-2012, 03:40 PM
BlkBb4u's Avatar
Silver Member
 
Join Date: Jul 2011
Location: Cleveland
Posts: 404
iTrader: (5)
BlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to allBlkBb4u is a name known to all
Re: Speedometer not Working

Problem Solved!!!! Ended up being the Full Speed Sensor assembly and not just the top electrical sensor,Now My Bb Screams when that Vtec Kicks! Lol Thanks For all the Help Guyz Really Appreciate it
__________________
Honda
Reply With Quote
  #12 (permalink)  
Old 01-26-2012, 04:01 PM
twokexlv6coupe's Avatar
little green ghouls, buddy!!
Photobucket
 
Join Date: Apr 2006
Location: kitten mittens
Posts: 17,844
iTrader: (9)
twokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond repute
Send a message via AIM to twokexlv6coupe
Re: Speedometer not Working

__________________

1995 Honda Prelude SE Turbo; 250whp, 275wtq @ 10psi Soldddd!!!

2000 Acura TL; DD
2005 Stage2.5+ Subaru WRB STi : RzKar!
Ivey Tuned - Advan - Cobb - Rallispec - CP - Perrin - ACT - KillerB - Carillo - TurboXS - Defi - Innovate - Walbro - DeatschWerks - Feal - H&R - Alpine - Infiniti - Curt

2001 Kawasaki STX1100 D.I. - Sold!
2007 Sea-Doo RXT 215; ET 127 +3 S/C impeller, DIY 3" intake, DIY resonator delete/free flow exhaust, DIY oil catch can, Rule 500gph bilge pump


Quote:
Originally Posted by Brash View Post
But you need that scoop on the hood. Is it true that they're big enough to fit your lunch box and all your camera gear in it?
Reply With Quote
  #13 (permalink)  
Old 02-06-2012, 08:24 PM
TheLudeDude's Avatar
Silver Member
 
Join Date: May 2010
Location: FL
Posts: 269
iTrader: (0)
TheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond repute
Re: Speedometer not Working

I'm having the same problem.. My RPM's are working, but the speedo needle either sits at 0 or bounces up and down through the mph's, and if i drive it, it starts bogging like it wants me to shift at 4k rpms like it's at it's rev limit.. My buddy and I took the whole speed sensor out today and cleaned it up and spun it and it seemed to be fine, but the problem still remains. I'm hoping i can just take the top electrical part off my buddies prelude and test it on mine so i don't have to go buying a whole new unit for like $100 with a chance of it not fixing the problem. Or just test his whole speed sensor since someone above me said it wasn't just the electrical part, but the whole thing.
I wonder if anyone else has had this problem and it turned out to be something other than the speed sensor though. >.<

Edit: Took out my buddies VSS and tried it on mine, but nothing. We first tried just changing the top electrical part from his, and that didn't work. Then we put the electrical part back on his complete VSS "Top half electrical, and bottom half gears", and we tried it in mine, and still nothing.. Then we even swapped out our gauge clusters, and still nothing. The speed sits at 0, and doesn't move at all right now, and after like 3mins of driving, a CEL comes on. And what's weird, sometimes it will 2 step forcing me to shift at like 4k rpms, but sometimes it will let me ride the gears smoothly and vtec will even crossover, but the speed sits at 0 the whole time. I'm going to go clean the connections seeing how i read it could be corroded or something, we'll see what happens..
__________________
__________________________________________________

1st: (93 Prelude) F22a1 to H23a JDM Blue Top - STOLEN
2nd: (95 Prelude) F20b - SOLD
3rd: (99 Civic, what a mistake) D16y8 - SOLD
4th: (94 Prelude) H23a1 to ?????? - CURRENT
__________________________________________________


Quote:
Originally Posted by M0B5TA View Post
in soviet Russia, prelude hates you

Last edited by TheLudeDude; 02-15-2012 at 04:24 PM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer Not Working - Already put in a new VSS mdoug445 5th Gen Honda Prelude 3 09-05-2011 02:47 PM
Speedometer stopped working mikeypx82 4th Gen Honda Prelude 11 02-05-2011 05:16 AM
speedometer stopped working check engine light came on 94vtec General Tech Talk 1 01-31-2011 09:11 PM
Speedometer stopped working White91Prelude 3rd Gen Honda Prelude 2 10-15-2010 03:29 AM
my odometer and speedometer arent working but everything else is good fishndad 2nd Gen Honda Prelude 4 09-19-2009 08:41 PM


All times are GMT -4. The time now is 05:20 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.