Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 4th Gen Honda Prelude

Thread Title
D4 Flashing, CEL, need codes.. PLEASE HELP :(

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05-14-2011, 10:17 PM
TheLudeDude's Avatar
Silver Member
 
Join Date: May 2010
Location: FL
Posts: 269
iTrader: (0)
TheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond repute
Icon5 D4 Flashing, CEL, need codes.. PLEASE HELP :(

I just did an h23a swap "JDM blue top" with an automatic h22 transmission and tcu, running a P72 ECU chipped and tuned for the h23a and i just finished putting it in and such, it's driveable in a way "Have to put key in shift release and put car in neutral, then start car, and shift from neutral", BUT, I have a CEL and flashing D4 on my speedo, i checked for the codes for the D4 and I got, "12, 37, 81, and 14 at the end." and my CEL code is 19, which indicates the Lock-Up Solenoid Valve is throwing the CEL code.

When I purchased this transmission from this place, it didn't have a speed sensor on it, and my buddy took one off of another honda transmission next to it, and we put it on the one I'm using now, my guess is that the speed sensor is bad, because I have the symptoms of a bad speed sensor, like:
Flashing D4, last night when i was driving, my speedo was acting up, jumping through the speeds sporadically, hesitation and roughness in shifting gears "side note, D1, and D4 don't work". It rumbles and idles irregularly, and it seems to be burning more fuel, and not running so great.

I plan on taking off the speed sensor from my old f22 transmission, since it worked fine when i was using it, and see if that solves my problem.
This just really stinks, cause when i start the car, i can't shift down from park, because the D4 light is flashing..

Any suggestions will be greatly appreciated, this is killing me right now, as it is keeping me from getting to work.. thank you.


~TheLudeDude
__________________
__________________________________________________

1st: (93 Prelude) F22a1 to H23a JDM Blue Top - STOLEN
2nd: (95 Prelude) F20b - SOLD
3rd: (99 Civic, what a mistake) D16y8 - SOLD
4th: (94 Prelude) H23a1 to ?????? - CURRENT
__________________________________________________


Quote:
Originally Posted by M0B5TA View Post
in soviet Russia, prelude hates you
Reply With Quote
  #2 (permalink)  
Old 05-15-2011, 02:46 PM
jackp0t's Avatar
Gold Member
 
Join Date: Feb 2010
Location: vancity , BC
Posts: 713
iTrader: (3)
jackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond reputejackp0t has a reputation beyond repute
Re: D4 Flashing, CEL, need codes.. PLEASE HELP :(

im sorry bro im not really familiar w/ the auto trans . my guess its the ecu. dont qoute me on that. my suggestion is find a p13 auto ecu to know for sure
Reply With Quote
  #3 (permalink)  
Old 05-15-2011, 10:13 PM
TheLudeDude's Avatar
Silver Member
 
Join Date: May 2010
Location: FL
Posts: 269
iTrader: (0)
TheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond reputeTheLudeDude has a reputation beyond repute
Re: D4 Flashing, CEL, need codes.. PLEASE HELP :(

yeah we put an auto p13 in and it got rid of the flashing D4, but it still locked the gear shift. The tranny uses all the gears with the p13, but they still slip a bit. Now i'm running a p14, just till i get the p72 working for this engine. my mechanic thinks that the reason the p72 ecu won't work yet, is because the wire for the tcu is relocated on the p72, so it's not giving the proper signal to the tcu. jeez, i wish i could figure this out.. i have the engine in, and everything, and it's running so nice, it just slips in gears and stuff cause the computers aren't right yet.
I also think i need an american h22 tcu, cause the tcu i have is for an h22a, and it might not be supported for my american wire harness or something. idk.. it's all so very confusing..
But for now, the p14 is running all the gears unlike the p72, but the p14 still slips in some gears, so i try to shift manualy for now.
__________________
__________________________________________________

1st: (93 Prelude) F22a1 to H23a JDM Blue Top - STOLEN
2nd: (95 Prelude) F20b - SOLD
3rd: (99 Civic, what a mistake) D16y8 - SOLD
4th: (94 Prelude) H23a1 to ?????? - CURRENT
__________________________________________________


Quote:
Originally Posted by M0B5TA View Post
in soviet Russia, prelude hates you
Reply With Quote
Reply

Tags
d4 codes, d4 flashing, speed sensor


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure light flashing :( SicktheDuck 5th Gen Honda Prelude 10 09-15-2015 11:06 AM
D4 light flashing (automatic) 98prelude89 General Tech Talk 3 10-17-2013 05:59 PM
flashing checkengine light lmcf 5th Gen Honda Prelude 6 10-11-2010 11:13 AM
Flashing CEL-power loss >4K CEL 4th Gen Honda Prelude 8 01-18-2010 10:59 PM
oil light flashing cikota 5th Gen Honda Prelude 6 05-10-2008 03:33 PM


All times are GMT -4. The time now is 12:53 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.