Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 3rd Gen Honda Prelude

Thread Title
Speedo doesnt work

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-22-2007, 05:24 PM
btnhfool's Avatar
Member
 
Join Date: Nov 2007
Location: Upstate NY
Posts: 92
iTrader: (0)
btnhfool is on a distinguished road
Send a message via AIM to btnhfool
Speedo doesnt work

Thats about all i can tell you. lol, anyone?
__________________
1989 honda prelude 2.0s
Reply With Quote
  #2 (permalink)  
Old 11-22-2007, 09:04 PM
twokexlv6coupe's Avatar
little green ghouls, buddy!!
Photobucket
 
Join Date: Apr 2006
Location: kitten mittens
Posts: 17,844
iTrader: (9)
twokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond repute
Send a message via AIM to twokexlv6coupe
check the VSS
Need help with 92 Prelude
__________________

1995 Honda Prelude SE Turbo; 250whp, 275wtq @ 10psi Soldddd!!!

2000 Acura TL; DD
2005 Stage2.5+ Subaru WRB STi : RzKar!
Ivey Tuned - Advan - Cobb - Rallispec - CP - Perrin - ACT - KillerB - Carillo - TurboXS - Defi - Innovate - Walbro - DeatschWerks - Feal - H&R - Alpine - Infiniti - Curt

2001 Kawasaki STX1100 D.I. - Sold!
2007 Sea-Doo RXT 215; ET 127 +3 S/C impeller, DIY 3" intake, DIY resonator delete/free flow exhaust, DIY oil catch can, Rule 500gph bilge pump


Quote:
Originally Posted by Brash View Post
But you need that scoop on the hood. Is it true that they're big enough to fit your lunch box and all your camera gear in it?
Reply With Quote
  #3 (permalink)  
Old 11-22-2007, 10:42 PM
Banned
 
Join Date: Jun 2007
Location: Delaware, Ohio
Posts: 925
iTrader: (0)
BoostedDreams will become famous soon enoughBoostedDreams will become famous soon enough
Send a message via AIM to BoostedDreams
go under the dash, and see if the cable is still plugged in
Reply With Quote
  #4 (permalink)  
Old 11-23-2007, 10:04 AM
Uncle Buck's Avatar
Gold Member
 
Join Date: Jan 2007
Location: Rapid City, South Dakota
Posts: 570
iTrader: (0)
Uncle Buck is on a distinguished road
Send a message via MSN to Uncle Buck Send a message via Skype™ to Uncle Buck
i had this issue.... but mine was simple.... the speedo cable popped out of the tranny.... its located on top below the TB
__________________


www.jdmdecals.com Check it out!
Reply With Quote
  #5 (permalink)  
Old 11-23-2007, 12:22 PM
btnhfool's Avatar
Member
 
Join Date: Nov 2007
Location: Upstate NY
Posts: 92
iTrader: (0)
btnhfool is on a distinguished road
Send a message via AIM to btnhfool
my odometer doesn't work either, is that linked?
__________________
1989 honda prelude 2.0s
Reply With Quote
  #6 (permalink)  
Old 11-23-2007, 03:12 PM
Uncle Buck's Avatar
Gold Member
 
Join Date: Jan 2007
Location: Rapid City, South Dakota
Posts: 570
iTrader: (0)
Uncle Buck is on a distinguished road
Send a message via MSN to Uncle Buck Send a message via Skype™ to Uncle Buck
well yea..... cus more or less the speedo cable comes to the dash... it then reads how fast/far you have travled..... its not on seperate cables...
__________________


www.jdmdecals.com Check it out!
Reply With Quote
  #7 (permalink)  
Old 11-24-2007, 02:02 AM
Banned
 
Join Date: Jun 2007
Location: Delaware, Ohio
Posts: 925
iTrader: (0)
BoostedDreams will become famous soon enoughBoostedDreams will become famous soon enough
Send a message via AIM to BoostedDreams
mabey some of the electrical wires, i had a problem where i needed to put in a new gauge cluster in, and i had to take everything apart and put in the new gauges. after words i reconnected the spedo but it didnt work, so i tried three times and finally i got it to work by pulling the speedometer line thats inside the cable out a little further, spinning it once and then carefully putting it back in the back of the gauge cluster.
Reply With Quote
  #8 (permalink)  
Old 11-25-2007, 03:37 PM
btnhfool's Avatar
Member
 
Join Date: Nov 2007
Location: Upstate NY
Posts: 92
iTrader: (0)
btnhfool is on a distinguished road
Send a message via AIM to btnhfool
what is the "tb"?
__________________
1989 honda prelude 2.0s
Reply With Quote
  #9 (permalink)  
Old 11-25-2007, 03:45 PM
twokexlv6coupe's Avatar
little green ghouls, buddy!!
Photobucket
 
Join Date: Apr 2006
Location: kitten mittens
Posts: 17,844
iTrader: (9)
twokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond reputetwokexlv6coupe has a reputation beyond repute
Send a message via AIM to twokexlv6coupe
throttle body
__________________

1995 Honda Prelude SE Turbo; 250whp, 275wtq @ 10psi Soldddd!!!

2000 Acura TL; DD
2005 Stage2.5+ Subaru WRB STi : RzKar!
Ivey Tuned - Advan - Cobb - Rallispec - CP - Perrin - ACT - KillerB - Carillo - TurboXS - Defi - Innovate - Walbro - DeatschWerks - Feal - H&R - Alpine - Infiniti - Curt

2001 Kawasaki STX1100 D.I. - Sold!
2007 Sea-Doo RXT 215; ET 127 +3 S/C impeller, DIY 3" intake, DIY resonator delete/free flow exhaust, DIY oil catch can, Rule 500gph bilge pump


Quote:
Originally Posted by Brash View Post
But you need that scoop on the hood. Is it true that they're big enough to fit your lunch box and all your camera gear in it?
Reply With Quote
  #10 (permalink)  
Old 11-25-2007, 03:50 PM
btnhfool's Avatar
Member
 
Join Date: Nov 2007
Location: Upstate NY
Posts: 92
iTrader: (0)
btnhfool is on a distinguished road
Send a message via AIM to btnhfool
ah haa i see. ill take a look at it today. which side of the firewall does the speedo cable come from, i want to try to stay away from taking the dash out just yet,unless i have to
__________________
1989 honda prelude 2.0s
Reply With Quote
  #11 (permalink)  
Old 11-25-2007, 10:13 PM
Uncle Buck's Avatar
Gold Member
 
Join Date: Jan 2007
Location: Rapid City, South Dakota
Posts: 570
iTrader: (0)
Uncle Buck is on a distinguished road
Send a message via MSN to Uncle Buck Send a message via Skype™ to Uncle Buck
first off you shouldnt have to pull off your dash to replace a speedo cable.... secondly what side is your cluster on?? should be a hit as to what side it comes out of the fire wall lol
__________________


www.jdmdecals.com Check it out!
Reply With Quote
  #12 (permalink)  
Old 11-26-2007, 11:07 AM
preludegoalie35's Avatar
Junior Member
 
Join Date: Nov 2007
Location: Hohenfels, Germany
Posts: 72
iTrader: (0)
preludegoalie35 is on a distinguished road
Send a message via MSN to preludegoalie35
I had that issue until I took it on the highway and ran it to like 80-85ish then it started to work.
__________________
1990 Honda Prelude SI- $550
B20A Engine and Tranny- $400
1997 BMW E36 316i- $2500
M42 Engine and Tranny- $300

Realizing that you have the two bastard engines of the bunch and will spend hours upon hours and years upon years hearing people with dem fancy bigger engines and finishing your build then smoking there ass's - A big ass headache but still priceless....until you wreck it.
Reply With Quote
  #13 (permalink)  
Old 11-26-2007, 01:40 PM
3rdGenCrazy's Avatar
Platinum Member
 
Join Date: Jul 2007
Location: 336, NC
Posts: 1,409
iTrader: (1)
3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute3rdGenCrazy has a reputation beyond repute
Send a message via AIM to 3rdGenCrazy
my speedo works but my "tripometer" doesnt work!
__________________

^Sig By-Dwend aka Daniel

'91 BA4 Honda Prelude Si Swapped B20A5
'93 S13 Nissan 240SX SE KA24DE

Not-on-the-H22-bandwagon: Member #5

member's ride thread: :::3rdGenCrazy::: 91 Si
my freebie 240sx: My Freebie 240sx!!!

44th US President: BARACK OBAMA
Reply With Quote
  #14 (permalink)  
Old 11-26-2007, 03:14 PM
btnhfool's Avatar
Member
 
Join Date: Nov 2007
Location: Upstate NY
Posts: 92
iTrader: (0)
btnhfool is on a distinguished road
Send a message via AIM to btnhfool
really? all you did was go 85, and it kicked in? haha
__________________
1989 honda prelude 2.0s
Reply With Quote
  #15 (permalink)  
Old 11-26-2007, 05:40 PM
Prelude13's Avatar
Hi.
 
Join Date: May 2006
Location: awd land :D
Posts: 6,583
iTrader: (2)
Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13
No VSS for your car, 88-89 mechanical.
Have you tried this?
Squeaky speedo cable...how to remove it?

You can pull the cable out with removing the entire cluster...

http://mustardcat.brinkster.net/p3g/...docablefix.htm

Maybe you have a broken gauge cluster. . .
__________________
'14 Impreza
'04 TSX sold
'90 Si sold


Everyone! Resource guides are here:
5th gen.
4th gen.
3rd gen.
2nd gen.
Reply With Quote
  #16 (permalink)  
Old 11-26-2007, 06:35 PM
btnhfool's Avatar
Member
 
Join Date: Nov 2007
Location: Upstate NY
Posts: 92
iTrader: (0)
btnhfool is on a distinguished road
Send a message via AIM to btnhfool
Thanks bro
__________________
1989 honda prelude 2.0s
Reply With Quote
  #17 (permalink)  
Old 11-29-2007, 11:02 PM
Newbie
 
Join Date: Nov 2007
Posts: 20
iTrader: (0)
Heath is on a distinguished road
If your car is an 88-89 its mechanical as mentioned and plugs in to the top of the tranny. There is an area of the cable that breaks and it becomes loose and slides out. It happened to mine. I stuffed it back in and secured it with silicone sealant. It's been working that way for many years now.
Clean the area around the cable with brake parts cleaner before applying the sealant.
You could even use duct tape as a temp. fix. Ghetto power!
Reply With Quote
  #18 (permalink)  
Old 11-30-2007, 05:47 PM
blackhawk2k7's Avatar
Newbie
 
Join Date: Oct 2007
Location: Stanwood
Posts: 26
iTrader: (0)
blackhawk2k7 is on a distinguished road
Quote:
Originally Posted by Uncle Buck View Post
i had this issue.... but mine was simple.... the speedo cable popped out of the tranny.... its located on top below the TB
i agree, i did a tranny transfer on my old accord, and it included plugging it (the speedo cable) back into the tranny, when i bought my f150 the previous owner did his '''own''' repairs and forgot to put it back in, later i found out it was dangeling
Reply With Quote
  #19 (permalink)  
Old 01-06-2010, 05:46 PM
1990si's Avatar
Bronze Member
 
Join Date: Dec 2009
Location: ohio 330h
Posts: 236
iTrader: (0)
1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts
Send a message via AIM to 1990si Send a message via Yahoo to 1990si
Re: Speedo doesnt work

ok i have a 1990si lude and the speedo fule gauge and tac dont work ive tried some stuff but any tips or tricks anyone
__________________
xxxxxx
Reply With Quote
  #20 (permalink)  
Old 01-18-2010, 09:44 AM
Not So New
 
Join Date: Jan 2010
Location: SD
Posts: 38
iTrader: (0)
911racing is on a distinguished road
Re: Speedo doesnt work

have you looked at the circuit board behind the cluster? i had a 91 crx that none of the guages would work except the tac, i ended up selling it before i fixed it but the honda technician i talked to pulled up a picture of the layout of the dash and we both think it was that so maybe you could start there if that helps at all.
Reply With Quote
  #21 (permalink)  
Old 01-21-2010, 01:12 PM
1990si's Avatar
Bronze Member
 
Join Date: Dec 2009
Location: ohio 330h
Posts: 236
iTrader: (0)
1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts
Send a message via AIM to 1990si Send a message via Yahoo to 1990si
Re: Speedo doesnt work

i pulled the dash in my 1990 and what it was was a ground wire was broken it was like if u put ur arm in the radio hole now everything but the temp gauge works
__________________
xxxxxx
Reply With Quote
  #22 (permalink)  
Old 01-28-2010, 10:42 PM
I'm New
 
Join Date: Jan 2010
Posts: 3
iTrader: (0)
aces691 is on a distinguished road
Re: Speedo doesnt work

yea i just got a 91 si and my speedo is electric and the trans is cable so can i get a electric sender and put it in the trans
Reply With Quote
  #23 (permalink)  
Old 02-02-2010, 01:07 PM
1990si's Avatar
Bronze Member
 
Join Date: Dec 2009
Location: ohio 330h
Posts: 236
iTrader: (0)
1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts
Send a message via AIM to 1990si Send a message via Yahoo to 1990si
Re: Speedo doesnt work

well whats the problem it may be something cheapir and easir
__________________
xxxxxx
Reply With Quote
  #24 (permalink)  
Old 03-26-2010, 02:58 PM
JDMLUD3's Avatar
Junior Member
 
Join Date: Mar 2010
Location: SOUTHERN CALIFAZ
Posts: 51
iTrader: (0)
JDMLUD3 is infamous around these parts
Re: Speedo doesnt work

hey any know were i can get a gauge cluster for my 90 , the bulbs in mine are out?
Reply With Quote
  #25 (permalink)  
Old 03-26-2010, 03:21 PM
Prelude13's Avatar
Hi.
 
Join Date: May 2006
Location: awd land :D
Posts: 6,583
iTrader: (2)
Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13
Re: Speedo doesnt work

Order the bulbs from Majestic Honda and refer to this thread for reference: INT: 3rd gen - How to Red-Out your gauge cluster

Dont let this thread topic go astray.
__________________
'14 Impreza
'04 TSX sold
'90 Si sold


Everyone! Resource guides are here:
5th gen.
4th gen.
3rd gen.
2nd gen.
Reply With Quote
  #26 (permalink)  
Old 03-26-2010, 03:30 PM
JDMLUD3's Avatar
Junior Member
 
Join Date: Mar 2010
Location: SOUTHERN CALIFAZ
Posts: 51
iTrader: (0)
JDMLUD3 is infamous around these parts
Re: Speedo doesnt work

yeah, also do you know anything about a led conversion for the gauge cluster>?
Reply With Quote
  #27 (permalink)  
Old 03-26-2010, 08:14 PM
I'm New
 
Join Date: Mar 2010
Posts: 7
iTrader: (0)
roamer is on a distinguished road
Re: Speedo doesnt work

got a 91 2.0si & had this problem, no speedo or odo. was the speed sensor in the trans. that had to be replaced.
Reply With Quote
  #28 (permalink)  
Old 03-27-2010, 05:01 PM
Not So New
 
Join Date: Jan 2010
Location: SD
Posts: 38
iTrader: (0)
911racing is on a distinguished road
Re: Speedo doesnt work

when i got my 89 prelude 2.0si its odometer had already stopped telling how many miles, then shortly after the speedometer cable went out so i took the cable and i still havent put a new one in but before it went out i had luckily found out that in 5th gear on the b20a5 with the speedo cables (im not sure if its the same for 90 91 preludes that had the electronic vss) that 25mph is 1.25 on the tach, 35mph is 1.75, 45mph is 2.25, 65mph is 3.25, 75mph is 3.75 and 80mph is 4 grand and each little mark is 5 mph. those are the speeds i have to use the most. but there were some variations in dashboards such as the usdm, canadian, and jdm mine i believe is the usdm. just thought i'd write this incase someone has the same problem, it seems thats a common problem in the 3rd gen preludes.
__________________
"it shakes because since it has so much balls if i press the gas any harder we'll go flying that way."
Reply With Quote
  #29 (permalink)  
Old 12-18-2010, 06:23 AM
1990si's Avatar
Bronze Member
 
Join Date: Dec 2009
Location: ohio 330h
Posts: 236
iTrader: (0)
1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts1990si is infamous around these parts
Send a message via AIM to 1990si Send a message via Yahoo to 1990si
Re: Speedo doesnt work

my temp gauge still is pegged my lude is a dirty dirty girl
__________________
xxxxxx
Reply With Quote
  #30 (permalink)  
Old 07-28-2014, 12:58 PM
MY FIRST POST YEAH!
Photobucket
 
Join Date: Jul 2014
Location: tulare country
Posts: 1
iTrader: (0)
msanmiguel is on a distinguished road
Re: Speedo doesnt work

Mines a 95 any tips
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:45 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.