Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 3rd Gen Honda Prelude

Thread Title
91 Prelude won't go over 20mph. Please help.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-28-2017, 03:10 PM
I'm New
 
Join Date: Jan 2017
Posts: 10
iTrader: (0)
Jasindude1 is on a distinguished road
91 Prelude won't go over 20mph. Please help.

My son has a 91 Prelude 5spd that has been running fine , just yesterday he was on his was home from work and said it would go past 20mph it didn't matter what gear he was in. The check engine light is on but has been on for a while so we didn't really bother to get it checked, but since this happened we are gonna do it when I get home from work. But wanted to get an idea of what people's thought would b and if u have experienced this before. Thanks for ur help
Reply With Quote
  #2 (permalink)  
Old 01-28-2017, 05:45 PM
I'm New
 
Join Date: Jan 2017
Posts: 10
iTrader: (0)
Jasindude1 is on a distinguished road
Re: 91 Prelude won't go over 20mph. Please help.

just a quick note and more info, it is Code 41 and also there is a knocking / rattle noise in the engine bay now, my son said when he started hearing the noise is when he started to experience the problem.
Reply With Quote
  #3 (permalink)  
Old 01-28-2017, 06:08 PM
I'm New
 
Join Date: Jan 2017
Posts: 10
iTrader: (0)
Jasindude1 is on a distinguished road
Re: 91 Prelude won't go over 20mph. Please help.

Here is a video of the engine noise we are hearing. I uploaded it on youtube.
https://youtu.be/yDI92UGPv6A
Reply With Quote
  #4 (permalink)  
Old 01-28-2017, 06:16 PM
I'm New
 
Join Date: Jan 2017
Posts: 10
iTrader: (0)
Jasindude1 is on a distinguished road
Re: 91 Prelude won't go over 20mph. Please help.

ok, I know i keep posting but want to give as much info as possible, I have included the video of the codes just in case i might be reading them wrong, but I believe I am also getting code 4 as well, please confirm.
https://youtu.be/akcX_Nk4lrE
Reply With Quote
  #5 (permalink)  
Old 01-28-2017, 10:57 PM
tassievteclude's Avatar
Gold Member
 
Join Date: Jul 2007
Location: Tasmania, Australia
Posts: 556
iTrader: (0)
tassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond reputetassievteclude has a reputation beyond repute
Re: 91 Prelude won't go over 20mph. Please help.

Yep, you have a code 4 and a code 41.

41 is the heated O2 sensor, this will usually make the car run pretty poorly (hesitating, misfiring, stalling, problems idling etc.) but doesn't generally cause what you are describing.

The code 4 is more troubling, it is the CKP (Crankshaft Position Sensor). It is possible it is just a faulty sensor and the ECU has thrown itself into limp mode to try and save itself, but the engine itself does not sound good at all. The CKP sensor is either in the distributor or next to the crank pulley (I can't remember which for 3rd gens). It'd be worth checking the timing and the condition of the timing belt to see if it has jumped a tooth too.
Reply With Quote
  #6 (permalink)  
Old 01-29-2017, 11:10 AM
I'm New
 
Join Date: Jan 2017
Posts: 10
iTrader: (0)
Jasindude1 is on a distinguished road
Re: 91 Prelude won't go over 20mph. Please help.

I already ordered a new dizzy from autozone with a lifetime warranty I'm gonna pull the old one today and take a look at the wires and try and track down that noise I'm hoping its just something that is loose, but it does sound like a valve knock I have experienced in the past with other vehicles, I will admit when I had my son check the oil it would barely register on the dip, so i think that might have something to do with it as well. Luckily the dizzy seems like a simple straight forward repair from the video I watched, my next questions is after that is done will i need to clear the codes or will it self clear?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow speedo 20mph off.. PLEASE help.. TheLudeDude 4th Gen Honda Prelude 3 06-18-2012 03:35 PM


All times are GMT -4. The time now is 10:46 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.