Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 3rd Gen Honda Prelude

Thread Title
Squeaky speedo cable...how to remove it?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-10-2007, 12:42 PM
Newbie
 
Join Date: Nov 2007
Posts: 13
iTrader: (0)
Miasma133 is on a distinguished road
Squeaky speedo cable...how to remove it?

Well, like the title says, my speedometer cable is squeaking like crazy and I need to figure out how to get the thing out and grease it up. I found the tutorial how to grease it up on prelude3g.com but I think I need it explained a little bit better. I am just not too sure how to go about removing it with out messing something up. Do I take the cable out from the instrument cluster or down where it connects to the engine? Any help is appreciated!
Reply With Quote
  #2 (permalink)  
Old 11-10-2007, 05:24 PM
Prelude13's Avatar
Hi.
 
Join Date: May 2006
Location: awd land :D
Posts: 6,583
iTrader: (2)
Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13 Prelude13
For your 88-89, you remove the cluster and there will be the speedo cable connection(highlighted in yellow) that connects to the speedo cable.

Grease that up!

__________________
'14 Impreza
'04 TSX sold
'90 Si sold


Everyone! Resource guides are here:
5th gen.
4th gen.
3rd gen.
2nd gen.
Reply With Quote
  #3 (permalink)  
Old 11-11-2007, 01:40 AM
Newbie
 
Join Date: Nov 2007
Posts: 13
iTrader: (0)
Miasma133 is on a distinguished road
ah ha! Thanks man...gotta a project tomorrow now!
Reply With Quote
  #4 (permalink)  
Old 11-15-2007, 12:47 AM
Banned
 
Join Date: Jun 2007
Location: Delaware, Ohio
Posts: 925
iTrader: (0)
BoostedDreams will become famous soon enoughBoostedDreams will become famous soon enough
Send a message via AIM to BoostedDreams
dude, it spent me 4 days, of working and 1 week of driving without a gauge pod because i disconnected everything but the spedo because i couldnt figure how to get it out. finally i yanked the sucker out and it was the happiest day of my life lol
Reply With Quote
  #5 (permalink)  
Old 11-15-2007, 01:07 AM
btnhfool's Avatar
Member
 
Join Date: Nov 2007
Location: Upstate NY
Posts: 92
iTrader: (0)
btnhfool is on a distinguished road
Send a message via AIM to btnhfool
My speedo doesn't even work....:(
__________________
1989 honda prelude 2.0s
Reply With Quote
  #6 (permalink)  
Old 11-16-2007, 01:03 AM
liensale's Avatar
Newbie
 
Join Date: Oct 2007
Location: Cathedral City, California
Posts: 13
iTrader: (0)
liensale is on a distinguished road
My speedo is bouncing, will greasing that spot fix it for me?
Reply With Quote
  #7 (permalink)  
Old 11-16-2007, 01:16 AM
Newbie
 
Join Date: Nov 2007
Posts: 13
iTrader: (0)
Miasma133 is on a distinguished road
Well, I tried greasing up that part of the cluster...but no luck. I disconnected the cable from the cluster and sure enough it was still squeaking like crazy. I am not too sure why I did not do that in the first place. Any tips on how to remove the cable itself, or how much it would cost to replace it? Thanks guys!
Reply With Quote
  #8 (permalink)  
Old 02-06-2009, 06:35 PM
I'm New
 
Join Date: Jan 2009
Posts: 1
iTrader: (0)
jeb1517 is on a distinguished road
Re: Squeaky speedo cable...how to remove it?

I have the same exact problem....super annoying, i'd rather just not even have the speedo working...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:28 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.