Honda Prelude Forum
 
Go Back   Honda Prelude Forum > Tech-Talk > 3rd Gen Honda Prelude

Thread Title
1989 prelude dohc si will fire up once a day for a cpl seconds then no spark

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-10-2015, 06:16 PM
I'm New
 
Join Date: Oct 2015
Posts: 9
iTrader: (0)
Planaphaseb is on a distinguished road
1989 prelude dohc si will fire up once a day for a cpl seconds then no spark

So i bought a 89 prelude si b20a5 dohc. If i go out after car sits for like overnight it will fire up for like 3 seconds then die n then has no spark i checked black yellow wire going into coil on top conector It had 12v i checked blue wire on ignitioncontrolmodule connector it had 12 volts this was with key in on position. And the little box that bolts to coil bolt that has 2 wires one going to distruibter i checked the one going to distruibter while turning over and it had like .3volts while turning over. When i put key in on position the check engine light stays on doesnt go out does that mean bad ecu or maine relay ..... And i dont see any flashes above computer. Please help
Reply With Quote
  #2 (permalink)  
Old 11-16-2015, 09:55 PM
Bronze Member
 
Join Date: Jul 2015
Location: Seattle WA USA
Posts: 152
iTrader: (0)
luda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond reputeluda8890 has a reputation beyond repute
Re: 1989 prelude dohc si will fire up once a day for a cpl seconds then no spark

Are you sure it is only loosing spark? If it is also loosing fuel I would follow the PGM-FI main relay diagnosis strategies.

Until we/I know for sure that spark is the only thing missing, I am going to address this as an only no spark condition. Is the car triggering any DTC's you can read via the red led in the hole under the carpet flap under the passenger side dash? If so, what is/are the code(s)?

Preform these checks as outlined in the service manual:

Disconnect the 6 pin connector from the igniter unit.
the igniter is the brownish black box near the coil, the plug is red and under a plastic cover packed with grease.

Turn on the ignition switch and measure the voltage from the blue wire to the black wire, you should have battery voltage. If no voltage, check from the blue wire to the strut bolt, if still no voltage repair the blue wire. If you have voltage from the blue wire to the strut mount, but not to the black wire, repair the black wire, this wire goes to G203.

If you have voltage from the blue to the black wire, measure from the black/yellow wire to the black wire, again you should have battery voltage. If you have no voltage, repair the black/yellow wire.

Now reconnect the igniter. You will need some back probes now.

With the ignition switch on, measure voltage from ECU terminal B15 to ECU terminal A18, and ECU terminal B17 to Ecu terminal A18. Both tests should yield battery voltage, if not, replace the ECU.

If you have voltage, unplug the ECU and the Igniter. Check the white wire at the igniter for continuity to ground, there should be no continuity. Next check fro continuity from this white wire to ECU connector B15 and B17. If this is okay, replace the igniter.

Run these quick tests and let us know what you found.
Reply With Quote
  #3 (permalink)  
Old 11-18-2015, 09:17 AM
Platinum Member
 
Join Date: Feb 2010
Location: Fayetteville, Ga.
Posts: 1,274
iTrader: (0)
Lespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond repute
Re: 1989 prelude dohc si will fire up once a day for a cpl seconds then no spark

Simply hook up a timing light and see if the light flashes when the engine is spinning. If it does then it's probably the main relay not sending voltage to your fuel pump or the pump might be shot.Try that.
Reply With Quote
  #4 (permalink)  
Old 11-20-2015, 02:05 AM
I'm New
 
Join Date: Oct 2015
Posts: 9
iTrader: (0)
Planaphaseb is on a distinguished road
Re: 1989 prelude dohc si will fire up once a day for a cpl seconds then no spark

So after trying many thing hooking up the jumper wire looking at computer for coils i tested all the wires even went to a junk yard n grabbed a ignitor main relay and distruibter. Well i changed the main relay and then when i turned the key the check engine light would shut off after about 2 seconds before it was constantly on. battery was about dead and after spraying either n stuff i was turning it over n it back fired and threw my timing way off i looked at cam gears while having the maine relay issue n it was good after the back fire its way off. so whats the easyest way to put it back into time the belt isnt to bad but il probbly get a new one but id like to just be able to put it back into time and hear it run then change the belt... Whats the proccess thank you very much
Reply With Quote
  #5 (permalink)  
Old 11-20-2015, 08:41 AM
Platinum Member
 
Join Date: Feb 2010
Location: Fayetteville, Ga.
Posts: 1,274
iTrader: (0)
Lespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond reputeLespaul59 has a reputation beyond repute
Re: 1989 prelude dohc si will fire up once a day for a cpl seconds then no spark

With both cams pointing straight up with arrows on the cam sprockets pointing up, There are two holes in the cams near the sprocket that you need to stick a drill bit or something similar in to lock them from moving. Think it was a #10 DRILL BIT BUT CAN'T REMEMBER.Then make sure the crank keyway is pointing up towards the engine NOT the earth pointing up. Remember that lude engines tilt back unlike other Honda engines. Don't forget to match To the flywheel mark at T.D.C That will be one line not the three close ones. That's for ignition timing.
Reply With Quote
Reply

Tags
1989 prelude, dohc, ecu, no spark, wont start


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 Prelude SI wont fire danny7560 2nd Gen Honda Prelude 2 08-21-2012 09:00 AM
fire hydrant meets prelude aj24 5th Gen Honda Prelude 6 02-17-2011 10:56 PM
97 honda prelude loses fire at plug scott1sc General Tech Talk 7 09-04-2010 08:42 PM
Prelude on Fire broncosi PreludeZone Videos 12 12-30-2007 02:34 PM


All times are GMT -4. The time now is 10:35 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


Copyright © 2006-2009 PreludeZone.com All Rights Reserved.